使用说明

Ndd使用说明

使用技巧
主题搭配
批量插入文本
批量查找替换
文件对比
插件工具箱
快捷键设置
自动化工具-宏
调用命令打开文件
文件与语法关联
自定义高亮标记颜色
多颜色文本内容高亮
自定义语言，高亮关键字
常见问题
注册版和非注册版
打开软件报错
文字或代码重叠
修改全部字体和大小
中英文字体没有对齐
字体和光标不对应
日文文字覆盖现象
右键菜单项的恢复
大文件显示不全的处理
高清电脑下调整界面大小
关于Ndd


使用技巧

notepad--是一个国产跨平台、轻量级的文本编辑器，是替换国外软件的一种选择。

其内置强大的代码对比功能，让你丢掉付费的beyond compare。

Notepad--的目标，致力于国产软件的可替代，专心做软件。

最新版本下载地址：https://gitee.com/cxasm/notepad--/releases/latest

Ndd 具备插件编写功能，如果您愿意开发插件，还请提交给我们。

做国人自己的免费编辑器，离不开您的支持，可以通过微信捐赠我们。

本节目录主要介绍Ndd的一些常用技巧，可依次展开目录阅读具体使用方法。


主题搭配

1.护眼模式。Ndd有丰富的主题模式。可以在设置---“主题与语法样式”中选择主题，也可以DIY，自己配置颜色。比如豆沙绿护眼色，在“选择主题”按钮左侧点击“全局设置”，再勾选“使用全局背景色”，然后在下方的配置卡中按图示参数配置豆沙绿色系，配置后点“保存”按钮。

2.行号与书签风格。比如，在Ruby blue主题下，重新设置行号栏宽度、书签栏颜色。主题设置模式下，点击“全局设置”按钮，调出详细界面。在“样式”下，选择“行号风格”，在“字体”栏可以设置字体样式、字体大小等。通过调解字体大小，可以控制行号栏的宽度；选中“书签风格”，然后在“背景色”配色卡中，选择自己喜欢的背景色，就可以将行号栏与书签栏设置为不同颜色。


批量插入文本

关于插入文本，Ndd提供了列块模式，有两种方法。

1.依次点击工具栏--编辑---列块模式，进入列块模式后，按住键盘ALT键不动，鼠标左键光标选择插入位置，然后从上至下划动（注意不要选中文本内容），可以将多个段落按列纵向切分，设置切分线。此时在切分线处输入要插入的内容，就可以批量纵向插入一列文本。插入的位置由光标所在位置决定，可以是段落的首尾或中间。

2.软件还提供了“列块编辑”模式，点击工具栏--编辑---列块编辑，勾选“插入文本”选框，输入欲插入的内容，返回Ndd编辑器主界面在要插入文本的位置用光标定位，再返回“列块编辑”框，点击“确定”即可。还可以按增量插入数字，设置重复次数插入等功能，用户可以自己探索使用。


批量查找替换

批量查找替换可通过正则表达式或“批量查找替换”按钮实现。使用的场景较多，比如文稿校对、编程代码批量替换等，Ndd提供了较实用的功能。

1.使用正则表达式。正则表达式就像WPS等办公软件里面的通配符，通过组合实现批量查找功能。比如，有一段文本，我想找到里面的所有数字则可以在查找框输入“\d+"，匹配中文字符使用[\x{4e00}-\x{9fa5}]+。正则表达式的使用在网上有很多教程。

2.使用“批量查找替换”功能。这是Ndd特色功能之一，可以批量设置关键字，对关键字在文本中进行匹配、替换。“批量查找替换”框，左右两侧都可以批量输入关键字，左右两侧行与行之间是一 一对应关系，输入完关键字后，点击“刷新”按钮读取内容，左右两侧文本框中的关键字可以点击“交换”按钮实现位置互换。目前批量关键字可以设置2万个。

关键字输入方法：一是可以在左右文本框中手工输入关键字，按enter键换行；二是可以批量导入，但导入时要符合Ndd的格式，具体可以先导出空白表，再按照空白表的表头格式制作批量替换表；三是可以批量粘贴。可以将excel中的某一列或某几列作为关键字，复制后粘贴到文本框中。


文件对比

Ndd提供了“文件/文件夹对比及同步”功能，这是Ndd的又一个特色功能。将国外收费的专业对比软件免费化，实现国产替代。可快速对比文本文件中的不同点，实时进行对比同步操作。支持文件夹/文件同步及对比，文件编码批量转换、批量修改，编辑修改，撤销修改；支持二进制bin文件对比等功能。是将CCompare（CCompare 绿色免费的文件对比同步工具）专业软件的部分功能集成到了文本编辑器中。


插件工具箱

Ndd提供了丰富的插件功能，其中108工具箱还在不断完善中，里面有一些小功能，可以体验一下：


快捷键设置

软件设置---快捷键管理，在管理菜单中可以双击修改快捷键。快捷键是稀缺资源，要省着用，注意不要冲突。常见的快捷键，基本都被注册完了。


自动化工具-宏

Ndd具备宏录制功能，可以将动作自动化重复执行，为普通电脑爱好者免去了编程的烦恼。比如，我们从网页上复制一段网文，往往需要去空行处理，这时候就可以把这个过程录制下来，保存为一个宏名称，以后再将文段粘贴到Ndd后就可以点击一下按钮，一键去空行。


调用命令打开文件

命令行下执行命令：

Notepad-- filepath -n linenum

filepath 文件的路径， -n 行号

这样会打开对应的文件，并且跳转到对应的行号。


文件与语法关联

使用Ndd打开一个文件，如果让该文件使用指定的语法进行高亮。举例来说，打开一个.c的文件，如果让ndd使用c语言的语法高亮？或者使用ndd打开一个文件后缀为.c1 .c2的文件，如何让ndd也使用c语言的语法高亮？

如下所示，在设置里面，语法文件后缀关联。

左边是支持的语言，右边是语言对应的文件后缀。用c语言举例来说，默认会把.h .c的文件后缀直接使用C语言进行语法高亮。如果您有一个文件，它的后缀是.test，但是也需要使用C语言进行语法高亮，则只需把test追加在上图的c,h后面即可。注意多个后缀之间，使用英文状态下的逗号进行分割。这样设置后，下次使用Ndd打开后缀为.test的文件时，ndd会自动选择c语言的语法进行高亮。以此类推。


自定义高亮标记颜色

Ndd的每种主题支持5中高亮颜色，而且该颜色都是可以自定义的。自定义的界面如下：标记样式1到5，在右边分别修改自己喜欢的背景色就好。


多颜色文本内容高亮

ndd每种主题支持5种不同的颜色，进行文本高亮。每种主题下面，文本高亮的颜色，都是可以自定义的。高亮功能在鼠标右键，和菜单里面都有。如下图所示：

一般使用右键即可，选择文本后，右键选择颜色进行高亮。也可以使用快捷键 F8 进行单词的高亮选择，默认颜色就是当前选中的高亮色。


自定义语言，高亮关键字

ndd 目前支持简单自定义语言，支持关键字高亮；支持类C语言的语法高亮。定义一个简单的语言，然后指定自定义关键字，对关键字进行高亮的设置步骤如下：

1）依次点击新建、输入自定义的语言名称。

2）输入自定义的关键字，关联文件后缀选择自定义的后缀。比如您的自定义语言假设是mytest，则关联的后缀名可以取 test ts等，只要不和其它现有语言冲突就行。最后保存。

3）之后凡是打开文件后缀为自定义语言后缀的文件，例子中是.test 或 .ts1时，Ndd会自动使用对应的语法进行高亮，目前只支持关键字高亮。对于类C语言，则可以支持函数识别，其余语法高亮等。


常见问题

使用过程中遇到问题请在gitee的Ndd专区反馈：https://gitee.com/cxasm/notepad--/issues。

日常使用交流可以在QQ群中进行，或者在Ndd的发布渠道所提供的平台进行探讨。

本节目录主要介绍用户在使用Ndd时遇到的问题，可依次展开目录寻求类似问题的解决办法。


注册版和非注册版

目前没有任何区别，软件主体永久免费使用。windows版本会永久免费使用。macOS如果上架到mac商场，后续会进行收费；但价格肯定是同类产品的一半或三分之一。


打开软件报错

打开报错，提示缺少VC***.DLL的情况：

缺少C++运行时库，可在Ndd的QQ群里下载，由热心网友上传。也可以在网上找C++运行库按需下载。注意：有网址提及兼容XP的最后版本是VC++ 2019 version 14.28.29213.0 = VisualCppRedist_AIO v0.35.0 ，而WIN SERVER2003 2008等老版本兼容问题还不清楚，若有知情者还望告知。


文字或代码重叠

代码或字体重叠这个问题可能与主题有关，主题所需字体，系统没有，电脑默认宋体。此时会造成字符重叠、光标无法定位到行尾问题。解决办法是，在主题与样式设置中，重新设置主题字体，比如设置为宋体，然后同时勾选“使用全局字体”、“使用全局字体大小”，点击保存按钮。

若文字发生了重叠和拥挤，高dpi双屏切换后，文字乱了等问题：

这种问题往往发生在多个屏幕分辨率不相等的场景下。比如两个显示器，分辨率不一样；还有使用投影仪，投影显示；还有高清屏幕，使用了一些屏幕缩放的配置等待。

该问题有部分原因，是和第五个问题类似的，就是系统缺少对应的字体。此时只需要修改系存在的等宽字体即可解决。

另外一个主要原因，就是缩放不一致导致。对于因为缩放问题，比如高清屏幕缩放等导致的紊乱，建议使用如下方式解决：

在ndd的运行目录下面，新建一个qt.conf。 qt.conf文件内容为：

[Platforms][Platforms]

WindowsArguments = dpiawareness=1

然后重启ndd即可。

这样即可解决因为多个屏幕分辨率不同，或者投影高清缩放等带来的文字重叠问题。


修改全部字体和大小

经常有人说，主题和语法里面，太多语法和样式了，每种字体和大小都去修改，太麻烦了。能不能提供一键全部修改所有语法字体和字体大小。是可以的，如下图：

在设置-主题语法样式中，依次选择1）全局设置 2）全局格式统一设置 3）全局样式覆盖所有语言。

然后勾选“使用全局字体” 和 “使用全局字体大小“两个选项。此时再修改字体和字体大小，就会一键修改全部语法的字体和字体大小了。

如果修改后觉得不满意，又想恢复回去，还是在这个界面，点击下面的重置按钮即可。重置后设置会恢复到系统默认的风格。

txt下面对中英不同字体和大小可以做独立设置。如果没有理解该用法，自己可以再学习一下。
中文、英文是txt语法下面的两种属性，每种属性的字体修改，只影响该属性本身，其余语法也都一样。


中英文字体没有对齐

中英文字体为什么没有对齐？类似如下现象或问题：

首先来说，没有对齐不是一个问题。只是有些时候，需要让中文和英文对齐，这样方便列编辑。总的来说，与当前文件设置的字体有关。每种主题下面的每种语法，都是可以自定义字体的。只有使用等宽字体，才能让编辑器中的文本看起来是对齐的。具体来说，如果有中文，需要支持中文字体编辑下面的对齐，我们建议使用宋体或新宋体字体，此两种字体是等宽字体。这样在有中文和英文混合的编辑情况下，才能让文本对齐，也就是例子“老葱”中的现象。如果是国外用户，说我不需要中文，全部是英文，则推荐使用英文等宽字体coriew new字体，这种字体对英文是等宽的，但是不支持中文。后续如果发现字体重叠，字体对不齐问题，请务必通过全局设置修改一下字体。推荐使用等宽字体。但是目前还没有发现一种字体，即支持中文等宽，也支持西文等宽，同时还能比较美观。虽然宋体是可以的，但是宋体下面的西文标点符号，看起来怪怪的。如果一键修改字体，见之前的说明：如何一键修改全部字体和大小。


字体和光标不对应

英文操作系统下，字体和光标不对应问题的处理，如：

解决方案：

1）安装字体或修改字体。英文系统下没有默认字体宋体导致，建议安装宋体字体。

2）或者统一修改txt语法字体coriew new即可。英文目前默认txt字体是宋体，而英文字体没有该字体，修改为系统有的英文字体coriew new即可。或者直接在全局里面修改，统一修改全局字体为coriew new。


日文文字覆盖现象

若日文[shift-jis]的文件出现文字覆盖的现象，如：

前文已经已提过，这种多半是字体缺少，或者字体不是等宽导致。统一设置为宋体或Courier New字体。

请在主题里面，修改全局字体试一下。


右键菜单项的恢复

右键菜单“新建txt文件”消失，如何恢复呢？

使用ndd 1.x 系列，安装包中修改windows注册表时，不小心删除了该项。2.x 系列从2.3开始，预计不会有该问题。如果该项丢失，恢复方法如下：

1）打开注册表，找到注册表项目HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.txt

2）在.txt上右键，选“新建-》项”，把新建项命名为ShellNew。如果有ShellNew就不用新建， 选中shellNew，然后“新建”-》“字符串值”，将名称设置为 Nullfile，值留空。具体如下图所示。

然后退出windows注册表，这样右键菜单“新建txt文件”就恢复了。


大文件显示不全的处理

打开一个大文本文件，比如1G，发现ndd没有显示完全，是不是有bug？

对于大文件，ndd采用分页加载机制。因为文件太大，一次性加载文件会内存爆炸。Ndd每次只显示一页，使用右边的滑块来进行翻页处理，而且是可以支持行跳转的。可通过右边的滑块，或者crtl+g跳转到指定的行来快速定位。


高清电脑下调整界面大小

ndd2.4是可以调整主界面的字体大小的。在一些高清屏幕上，因为屏幕分辨率很高，导致界面字体看起来很小，不方便查看。此时可以在设置里面调整主界面的字体大小。在设置-选项下面，如下图所示：调整字体大小为合适的大小即可。

另外关于主界面工具栏图标大小的问题，目前提供三种大小的图标，也是可以切换的。在视图-图标大小中设置：可以选择为48x48 即可，不过目前图标还比较丑陋，得进一步继续完善。


关于Ndd

notepad--，简称 Ndd，为何叫这个名字还真有一段故事。这是一个使用 C++ 编写的开源文本编辑器，可用于编写代码或者处理文本，支持 Win/Linux/Mac 平台。Notepad-- 的目标，致力于国产软件的可替代。如有BUG，建议先升级到最新版，最新版本可以从下方链接或者QQ群获取。

subtwo : Ndd 的国际发行发布。为了在国外推广和宣传，使用 subtwo 或 subtwo editor 在国外做宣传。在 mac os redhat 等平台使用更加容易搜索的名字。

[软件下载](点击获取),可在这里按下顶部的issue按钮提BUG和建议，以免在QQ群中聊天消息被冲刷遗忘。

[插件下载](点击获取)，这里会引用并列举出 Ndd 的所有第三方插件。

[联络方式](QQ群：372613546(已满） 959439826(已满）728578708（空闲） 用户群，做Ndd的问题反馈、功能建议等。

[开发者 QQ群] 616606091 开发群，建议懂CPP/QT、愿意参与Ndd项目代码贡献的开发人士加入。

 -----本CHM由雲深不知處制作，非官方。